[Openerp-community] [Merge] lp:~openerp-community/openobject-addons/fix-1105067-account_payment_reference_type into lp:openobject-addons

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[Openerp-community] [Merge] lp:~openerp-community/openobject-addons/fix-1105067-account_payment_reference_type into lp:openobject-addons

Peter Langenberg
Peter Langenberg has proposed merging lp:~openerp-community/openobject-addons/fix-1105067-account_payment_reference_type into lp:openobject-addons.

Requested reviews:
  OpenERP Core Team (openerp)
Related bugs:
  Bug #1105067 in OpenERP Addons: "account_payment: structured reference type is not reflected when importing from invoice"
  https://bugs.launchpad.net/openobject-addons/+bug/1105067

For more details, see:
https://code.launchpad.net/~openerp-community/openobject-addons/fix-1105067-account_payment_reference_type/+merge/150553

Please merge.
--
https://code.launchpad.net/~openerp-community/openobject-addons/fix-1105067-account_payment_reference_type/+merge/150553
Your team OpenERP Community is subscribed to branch lp:~openerp-community/openobject-addons/fix-1105067-account_payment_reference_type.

=== modified file 'account_payment/wizard/account_payment_order.py'
--- account_payment/wizard/account_payment_order.py 2012-12-06 14:56:32 +0000
+++ account_payment/wizard/account_payment_order.py 2013-02-26 12:57:33 +0000
@@ -88,6 +88,7 @@
                     'partner_id': line.partner_id and line.partner_id.id or False,
                     'communication': line.ref or '/',
                     'date': date_to_pay,
+                    'state': 'structured' if line.invoice and line.invoice.reference_type != 'none' else 'normal',
                     'currency': (line.invoice and line.invoice.currency_id.id) or line.journal_id.currency.id or line.journal_id.company_id.currency_id.id,
                 }, context=context)
         return {'type': 'ir.actions.act_window_close'}


_______________________________________________
Mailing list: https://launchpad.net/~openerp-community
Post to     : [hidden email]
Unsubscribe : https://launchpad.net/~openerp-community
More help   : https://help.launchpad.net/ListHelp
Reply | Threaded
Open this post in threaded view
|

Re: [Openerp-community] [Merge] lp:~openerp-community/openobject-addons/fix-1105067-account_payment_reference_type into lp:openobject-addons

Naresh(OpenERP)
Hi,

This proposal is a duplicate of https://code.launchpad.net/~openerp-dev/openobject-addons/7.0-opw-584984-dhs/+merge/146352 proposed much earlier, thus I would reject this one for the sake of clarity.


Thanks for your work !

Regards,
Naresh Soni
OpenERP Enterprise Services
--
https://code.launchpad.net/~openerp-community/openobject-addons/fix-1105067-account_payment_reference_type/+merge/150553
Your team OpenERP Community is subscribed to branch lp:~openerp-community/openobject-addons/fix-1105067-account_payment_reference_type.

_______________________________________________
Mailing list: https://launchpad.net/~openerp-community
Post to     : [hidden email]
Unsubscribe : https://launchpad.net/~openerp-community
More help   : https://help.launchpad.net/ListHelp
Reply | Threaded
Open this post in threaded view
|

[Openerp-community] [Merge] lp:~openerp-community/openobject-addons/fix-1105067-account_payment_reference_type into lp:openobject-addons

Naresh(OpenERP)
In reply to this post by Peter Langenberg
The proposal to merge lp:~openerp-community/openobject-addons/fix-1105067-account_payment_reference_type into lp:openobject-addons has been updated.

    Status: Needs review => Rejected

For more details, see:
https://code.launchpad.net/~openerp-community/openobject-addons/fix-1105067-account_payment_reference_type/+merge/150553
--
https://code.launchpad.net/~openerp-community/openobject-addons/fix-1105067-account_payment_reference_type/+merge/150553
Your team OpenERP Community is subscribed to branch lp:~openerp-community/openobject-addons/fix-1105067-account_payment_reference_type.

_______________________________________________
Mailing list: https://launchpad.net/~openerp-community
Post to     : [hidden email]
Unsubscribe : https://launchpad.net/~openerp-community
More help   : https://help.launchpad.net/ListHelp
Reply | Threaded
Open this post in threaded view
|

Re: [Openerp-community] [Merge] lp:~openerp-community/openobject-addons/fix-1105067-account_payment_reference_type into lp:openobject-addons

Martin Trigaux (OpenERP)
In reply to this post by Peter Langenberg
Review: Approve

Thansk for the patch, these have been merged into addons 7.0 at revision 9207 (revision-id: [hidden email]-20130607152644-4om98wo6mu3hesfo)
--
https://code.launchpad.net/~openerp-community/openobject-addons/fix-1105067-account_payment_reference_type/+merge/150553
Your team OpenERP Community is subscribed to branch lp:~openerp-community/openobject-addons/fix-1105067-account_payment_reference_type.

_______________________________________________
Mailing list: https://launchpad.net/~openerp-community
Post to     : [hidden email]
Unsubscribe : https://launchpad.net/~openerp-community
More help   : https://help.launchpad.net/ListHelp
Reply | Threaded
Open this post in threaded view
|

[Openerp-community] great app

debaetsr
In reply to this post by Peter Langenberg
Hey!

I think  this app is gonna be helpful for you, read  more here <http://common.hjelm.ws/e4mwpm>

Thanks for your consideration, ruben



--
https://code.launchpad.net/~openerp-community/openobject-addons/fix-1105067-account_payment_reference_type/+merge/150553
Your team OpenERP Community is subscribed to branch lp:~openerp-community/openobject-addons/fix-1105067-account_payment_reference_type.

_______________________________________________
Mailing list: https://launchpad.net/~openerp-community
Post to     : [hidden email]
Unsubscribe : https://launchpad.net/~openerp-community
More help   : https://help.launchpad.net/ListHelp